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METHODOLOGY FOR CO-REGISTRATION OF IMAGE STACKS 
USING ADOBE PHOTOSHOP© 

 
SUMMARY OF THE ROBERTS DIFFERENCE STACKING METHOD 

 
This method of stacking astronomical images, using Adobe Photoshop© to enhance detail and reduce 
image grain, is due to Roberts (2003).  According to Roberts, Photoshop© is not designed to ADD digital 
images in the same manner as professional astronomical imaging processing software.  However, 
Photoshop is capable of combining pairs of images, the result of which, according to the method’s 
author, is identical to stacking two images with imaging processing software.  A stack consists of a base 
image (opacity 100%) and an image overlay where the opacity is set at exactly 50%.  Thus, the image 
overlay’s pixel value masks the underlying base image pixel value by 50%, and the sum of both is 
equivalent to the ADD function in scientific imaging processing software.  
 
The key principle of this method is to iteratively stack multiple pairs of previous, similarly processed, 
image stacks.   Each stack of two images results in a single image.  Another stack of two other images 
results in another single image.  If these two stacks are themselves stacked, the result is a composite of a 
total of four images; likewise, stacking a pair of four-image stacks results in a composite of eight 
images, and so forth.  Therefore, to properly use the method requires a total of 2k primary images, where 
k equals the number of stacking levels. 
 
Imagine a processing tree where each single image and each successive paired image stack is 
represented by a box (Fig. 1). It is helpful to have a method for keeping track of what branch (or level) 
you are on.  One naming convention that I use is described below. 

 

 
 
Fig. 1 – Processing tree for eight rotated and masked images (Level 0).  At the base is the final stacked 
image (box at Level 3) resulting from stacking a pair of images (two boxes at Level 2) that, in turn, were 
the result of stacking a pair of images (Level 1).  The connections are analogous to branches of a tree. 
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DEFINITION OF TERMS 
 

Ephemeris – A table of attributes of an astronomical object at a specified time.  See APPENDIX A  
Ephemeris of Solar System Dynamics for details. 
 
Image – A FITS image saved as a 16-bit TIFF file.  The dimensions of the image are 512px x 512px. 
 
Layer – A component of a Photoshop© .psd file that contains graphical information (such as raster, 
vector, point or text) in a planar format, analogous to a semi-transparent acetate overlay. 
 
Level – A hierarchical designation of similarly processed stacks in the processing tree.  By definition, 
the original image files are at Level 0.  When rotation and/or registration and stacking steps have been 
completed on a pair of Level 0 files, the result is a Level 1 file. 
 
Overlay Mask – A PS layer consisting of a black background with a circular cutout.  The cutout 
diameter (in pixels) is the diameter of the Venus image for the stack being considered. 
 
PS – Adobe Photoshop© 
 
Pair index – After two images are stacked, the pair index n-m refers to the base image (n) and the 
overlaid image (m).  See A USEFUL NAMING CONVENTION section below. 
 
Rectify – The general process needed to rotate and, if necessary, to scale an image 
 
Register – Aligning two images so that corresponding features of each have the same x- and y- image 
coordinates 
 
Rotate – Rotation (in degrees) of the image about its center.  A typical requirement might be to rotate the 
y-axis to be parallel to the N-S meridian 
 
Stack – Merging of two registered images, typically Flattened by PS to reduce file size 
 

TYPOGRAPHIC AND OTHER CONVENTIONS USED HERE 
 
 IMPORTANT STEP! 
File name example: /LEVEL 0 TIF IMAGES/0-1.tiff 
PS command example: Layer>Layer From Background 
Layer name example: Layer 0-1 rot 
Center of mask: x: 255px; y: 255px defined by convention 
 

PROCESSING STEPS 
 
The following lists the basic processing steps necessary to stack two images, such that the polar axes of 
Venus in the resultant image are oriented vertically and the extraneous surrounding sky around Venus is 
masked.  Rectification is assisted by using a centered and circular opening of a mask.  Fig. 2 shows the 
sequence of the processing steps necessary to rotate and center each image. 
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             (a)                              (b)                             (c)                               (d)                              (e) 
 
Fig. 2 – Sequence of steps required to rectify and register an image: (a) Convert FITS image file to TIFF 
image file; (b) Rotate image so that N-S direction is vertical; (c) Create a centered mask overlay whose 
circular opening is the same width as the diameter of Venus; (d) Move the image file under the mask so 
that it is centered on the opening; (e) Flatten image and mask. 
 

STEP 1 -- Convert FITS files to TIFF format 
 
In FITS Liberator (or similar viewing program) adjust contrast, if necessary, convert all .fits files to 16-
bit . tiff files.  Contrast can be also adjusted in Photoshop 
 

STEP 2 -- Create Mask 
 
This step creates a mask that is useful for centering images and removing distracting and extraneous sky 
glow around Venus.  The diameter of the circular hole in the mask is determined experimentally from an 
image taken during the time interval of exposure or from an ephemeris of Venus; see APPENDIX A.  In 
this example, assume that the diameter is 306 px. 
 
Create a base layer  File>New Name: Background 
      Size: 512 px x 512 px 
      Background color: Black 

Foreground color: Black 
    Layer>New>Background From Layer 
Save file   File>Save As>BlackBackground.psd 
Set six guides (see Fig. 2c) View>New Guide Orientation: Vertical 
        Position: x = 102px, 255px, 408px 

Orientation:Horizontal 
        Position: y = 102px, 255px, 408px 
Select Elliptical Marquee Tool 
Draw a circle 
In Toolbar, set size  Style: Fixed Size   Width: 306 px Height: 306 px  
Select Move Tool 
Drag box so that the circle is approximately bounded by the guides 
 Finalize centering  Use cursor keys to move the circle ± 1px at a time 
Cut hole in mask  Edit>Cut 
 Rename layer  Mask306px 
Save file   File>Save As>Mask306px.psd  
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STEP 3 -- Rotate Image (optional) 
 
Open TIFF image  File>Open>0-1.tiff 
Flip image option   Image>Rotate Canvas>Flip Canvas Horizontal 
Rotate image    Image>Rotate Canvas>Arbitrary… Angle:  2.5°  CW 
Create new layer  Layer>New>Layer From Background 
 Rename new layer   Layer 0-1 rot    
Select layer   Select>All 
Copy layer to clipboard Edit>Copy 
Save as new file  File>Save As: 0-1rot.tif  Format: TIFF 
Close file    File>Close  
 

STEP 4 -- Align with Mask 
 
Open black background layer   File>Open>BlackBackground 
Open overlay mask of 306px diameter File>Open>Mask306px 
Move layer Mask306px to top 
Paste rotated image from clipboard  Edit>Paste 
 Rename new Layer1   Layer 0-1 rot 
Select layer Layer 0-1 rot 
Select the Move tool 
Drag layer to the approximate center of the mask’s opening (see Fig. 2d) 
Finalize centering (Fig. 2e)  Use cursor keys to move image ± 1px at a time 
Save as new file   File>Save As: 0-1reg.tif 
Flatten image and mask  Layer>Flatten Image 
Rename Background layer   Layer 0-1 reg flat 
Save      File>Save 
 
 Repeat Rotate Image and Align with Mask steps for 0-2.tif 
 

STEP 5 -- Registration and Stacking of Image Pairs 
 
 Once image pairs have been individually processed, they may be registered and stacked 
Open base layer   File>Open>0-1reg.tif 
Open overlay layer  File>Open>0-2reg.tif 
 
Overlay layer is now Active 
 Make sure this layer has a unique name (e.g., Layer 0-2 reg) 
Select layer    Select>All 
Copy layer to clipboard  Edit>Copy 
Close overlay file   Close 
 
Base image is now Active 
Paste the previously copied image Edit>Paste 
 Rename Layer 1    Layer 0-2 reg 
Select Layer 0-2 reg and move to top 
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In Layers palette, change Layering Mode from Normal  Difference 
Image should now be nearly black with some gray pixels 
 Align images with cursor keys ± 1 px at a time in all directions to minimize the number of gray pixels 
In Layers palette, change Layering Mode from Difference  Normal 
 Set Opacity of top layer to exactly 50% 
Flatten image layers    Layer>Flatten 
 The flattened image layer name is Background 
Rename Background layer  Layer 1-1 
Save registered image   File>Save As> /LEVEL 1 TIF Images/1-1.tif 

 
A USEFUL NAMING CONVENTION 

 
The stacking methodology registers pairs of images and combines the pixel values into a composite 
image.  It is helpful to use an unambiguous naming convention for the processed and stacked images.  
One simple convention is n-m.tif where n is the level of the iteration (0 indicating the original image, 1 
being the first iteration, 2 the second, etc.) and m is the sequence index of the original (that is, not 
stacked) registered images.   
 
Example:  Chose four original images, say 0-1.tif, 0-2.tif, 0-3.tif and 0-4.tif.  The first two are paired and 
registered; name the flattened result 1-1.tif.  The second pair, 0-3.tif and 0-4.tif are paired, registered and 
flattened as 1-2.tif.  Then 1-1.tif and 1-2.tif are co-registered and flattened; the result is named 2-1.tif. 
 
0-1.tif + 0-2.tif -> 1-1.tif  LEVEL 0 pair yields LEVEL 1 image 
0-3.tif + 0-4.tif -> 1-2.tif  LEVEL 0 pair yields LEVEL 1 image 
 
1-1.tif + 1-2.tif -> 2-1.tif  LEVEL 1 pairs yield LEVEL 2 image 
 
If eight images are considered, then the result would be: 
 
0-1.tif + 0-2.tif -> 1-1.tif  LEVEL 0 pair yields LEVEL 1 image 
0-3.tif + 0-4.tif -> 1-2.tif  LEVEL 0 pair yields LEVEL 1 image 
0-1.tif + 0-2.tif -> 1-3.tif  LEVEL 0 pair yields LEVEL 1 image  
0-7.tif + 0-8.tif -> 1-4.tif  LEVEL 0 pair yields LEVEL 1 image 
 
1-1.tif + 1-2.tif -> 2-1.tif  LEVEL 1 pairs yield LEVEL 2 image 
1-3.tif + 1-4.tif -> 2-2.tif  LEVEL 1 pairs yield LEVEL 2 image 
 
2-1.tif + 2-2.tif -> 3-1.tif  LEVEL 2 pairs yield LEVEL 3 image 
 
Note that in this example, eight images are stacked to produce the final image 3-1.tif in seven steps.  The 
diagram for the processing tree is shown in Fig. 3. 
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Fig. 3 – Processing tree for eight registered images (LEVEL 0) with numerical IDs. 
 

APPENDIX A 
Ephemeris of Solar System Dynamics 

 
An ephemeris is a table of attributes of an astronomical body, such as a star, planet, satellite (moon or 
artificial), or comet.  Attributes may include the physical properties of the body, such as mass, radius 
(polar and equatorial), and average density.  Other attributes are time-dependent, such as celestial 
coordinates, magnitude, and distance in a spatial and temporal reference system.  For our purposes, we 
will use an ephemeris that provides a table of key properties of Venus at times specified in the FITS 
image header.  Our example is 16 FITS images recorded between 16:20 and 16:57 UTC on 13 
December 2010. 
 
The application we use is found at the JPL HORIZONS Web-Interface (http://ssd.jpl.nas.gov/horizons/). 
At the top of the HORIZONS Web-Interface is a section where the ephemeris type, target body, 
observer location, and time span are specified.  In addition, it is necessary to specify settings for what 
table values are to be displayed.  Fig. 4 shows the Current Settings needed for this example. 
 

 
 

Fig. 4 – Settings required to generate an ephemeris of Venus as observed at the NASA IRTF on Mauna 
Kea, Hawaii on 13 December 2010.  The ephemeris will show values of three quantities: (13) angular 
diameter of Venus in arc-sec (Ang-diam); (14) longitude and latitude of sub-observer point in Venus 
coordinates (Ob-lon,Ob-lat); and (17) position angle (degrees) of the North Pole (NP.ang) and its 
angular distance (arc-sec) (NP.dist) from the sub-observer point at one-hour intervals.   
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Fig. 5 shows a tabulation of hourly values of these quantities.  The first thing that we notice is that the 
diameter of Venus changes very slowly between the first and last image of the sequence: ~0.01 arc-sec 
in the 27 minutes for an average diameter of 34.76 arc-sec.  An independent determination of the plate 
scale found an average of 0.114 arc-sec/pixel.  This means that the average diameter of the Venus image 
on the plate is 306 pixels. 
 

 
 
Fig. 5 – Ephemeris for Venus 00:00 UTC on 13 December 2010 to 00:00 UTC on 14 December 2010.  
Table columns are defined in Fig. 6 and Fig. 7 shows notation used to determine solar and lunar 
properties at the given time. 
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Fig. 6 – Detailed discussion of definitions of Ang_diam, Ob-lon, Ob-lat, NP.ang, and NP.dist. 
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Fig. 7 – Details about the time standard (UTC) and the solar and lunar presence at the specific time 
interval. 
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